Llenar matriz sin repetir valores

0 votos
preguntado por DanielC4 (120 puntos) Jun 6, 2016 en General
Hola, estoy haciendo un algoritmo pero me falta una parte... en el algoritmo el usuario debe ingresar valores para llenar una matriz 3x3 y que además éstos entén entre 0 y 9 pero no debe permitir que se repitan valores... Permitiendo repetir valores sería así:

Definir i, j, a como entero
Dimensión m[3,3]

Para i<-1 Hasta 3 Con Paso 1 Hacer
Para j<-1 Hasta 3 Con Paso 1 Hacer
Escribir "Introduce un numero para la posicion " i "," j
leer a
Mientras a<0 o a>9 Hacer
Escribir "Ha ingresado un numero fuera del rango, por favor digite nuevamente un numero entre 0 y 9."
Leer a
Fin Mientras
Fin Para
Fin Para

Pero cómo hago para que no deje repetir valores????

2 Respuestas

0 votos
respondido por Diego A (300 puntos) Jun 23, 2016
Hola.

Lo que podrías hacer es utilizar una lista o un array para guardar los valores que va ingresando.

Y justo antes de guardar los valores dentro de la matriz podrías verificar el array para comprobar que no lo haya ingresado previamente.

Saludos, espero haberte ayudado.
0 votos
respondido por Jacobo Daniel Olvera (140 puntos) Jun 30, 2016
Hola Daniel

Lo que podrias hacer seria despues de que cada vez que intentas ingresar un valor recorras tu matriz y compares ese valor con todo lo que hay en tu matriz y si es igual entonces no lo ingreses o tu muestre algun error algo asi como...

for (int i; i<=matriz.lenght; i++){

     for (int j; int <=matriz[0].lenght; j++){

if (valoringresado== matriz[j]){

System.out.println("Este valor ya existe");

} else{

matriz[x][y]=valoringresado;

    }

  }

}

Espero haberte ayudado saludos!!

Preguntas relacionadas

0 votos
8 respuestas
preguntado por LUIS FERNANDO MOLINA (160 puntos) Ene 28, 2016 en Java
0 votos
1 respuesta
preguntado por mine77 (120 puntos) Ene 28, 2016 en Java
0 votos
0 respuestas
preguntado por Rodriguez (150 puntos) Ene 28, 2016 en General
0 votos
0 respuestas
preguntado por denisstefa (160 puntos) Ene 28, 2016 en General
Bienvenido a Dudas de Programación, donde puedes hacer preguntas y recibir respuestas sobre los problemas más frecuentes de los lenguajes de programación, frameworks de desarrollo y bases de datos que utilices. Foro de Línea de Código
...